close

[Solved] ‘AmplifySignOut’ is not exported from ‘@aws-amplify/ui-react’

Hello Guys, How are you all? Hope You all Are Fine. Today I am installed aws-amplify @aws-amplify/ui-react with npm install aws-amplify @aws-amplify/ui-react command But As I run my app I am facing following error ‘AmplifySignOut’ is not exported from ‘@aws-amplify/ui-react’ in ReactJs. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How ‘AmplifySignOut’ is not exported from ‘@aws-amplify/ui-react’ Error Occurs ?

I am installed aws-amplify @aws-amplify/ui-react with npm install aws-amplify @aws-amplify/ui-react command But As I run my app I am facing following error.

'AmplifySignOut' is not exported from '@aws-amplify/ui-react'

How To Solve ‘AmplifySignOut’ is not exported from ‘@aws-amplify/ui-react’ Error ?

  1. How To Solve 'AmplifySignOut' is not exported from '@aws-amplify/ui-react' Error ?

    To Solve 'AmplifySignOut' is not exported from '@aws-amplify/ui-react' Error You Just need to Downgrade ui-react to 1.2.5 Just edit this line in package.json: “@aws-amplify/ui-react”: “^1.2.5” Now, Your error might be solved.

  2. 'AmplifySignOut' is not exported from '@aws-amplify/ui-react'

    To Solve 'AmplifySignOut' is not exported from '@aws-amplify/ui-react' Error You Just need to Downgrade ui-react to 1.2.5 Just edit this line in package.json: “@aws-amplify/ui-react”: “^1.2.5” Now, Your error might be solved.

Solution 1: Downgrade ui-react

You Just need to Downgrade ui-react to 1.2.5 Just edit this line in package.json.

"dependencies": {
    "@aws-amplify/ui-react": "^1.2.5",
}

Now, Your error might be solved.

Summary

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you?

Also, Read