close

[Solved] Error: The compiler compliance specified is 1.8 but a JRE 15 is used

Hello Guys, How are you all? Hope You all Are Fine. Today I am facing the following error Error: The compiler compliance specified is 1.8 but a JRE 15 is used in Java. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How Error: The compiler compliance specified is 1.8 but a JRE 15 is used Error Occurs?

Today I am facing the following error Error: The compiler compliance specified is 1.8 but a JRE 15 is used in Java.

How To Solve Error: The compiler compliance specified is 1.8 but a JRE 15 is used Error ?

  1. How To Solve Error: The compiler compliance specified is 1.8 but a JRE 15 is used Error ?

    To Solve Error: The compiler compliance specified is 1.8 but a JRE 15 is used Error Go to windows>preference>java>compiler. Tick the check box “use default compliance setting” then apply and close.

  2. Error: The compiler compliance specified is 1.8 but a JRE 15 is used

    To Solve Error: The compiler compliance specified is 1.8 but a JRE 15 is used Error Go to windows>preference>java>compiler. Tick the check box “use default compliance setting” then apply and close.

Solution 1

Possible solution:

  1. Right-click on your project and select "Android Tools -> Fix Project Properties". (if this doesn’t work, try the following option)
  2. Right-click on your project and select "Properties -> Java Compiler", check “Enable project specific settings” and select 1.5 or 1.6 from the “Compiler compliance settings” select box.
  3. Under Window -> Preferences -> Java -> Compiler, set Compiler compliance level to 1.5 or 1.6.

Solution 2

Go to windows>preference>java>compiler. Tick the check box “use default compliance setting” then apply and close. Right-click on the project and go to build path> configure build the path Under Libraries tab remove JRE System Library and click on add library select the radio box execution environment and select the environment Apply nad Close

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you? Thank You.

Also, Read