close

How do I install the most recent Tensorflow (here: 2.2) on Windows when conda does not yet support it?

Hello Guys, How are you all? Hope You all Are Fine. Today We Are Going To learn about How do I install the most recent Tensorflow (here: 2.2) on Windows when conda does not yet support it in Python. So Here I am Explain to you all the possible Methods here.

Without wasting your time, Let’s start This Article.

How do I install the most recent Tensorflow (here: 2.2) on Windows when conda does not yet support it?

  1. How do I install the most recent Tensorflow (here: 2.2) on Windows when conda does not yet support it?

    Better do not use pip install at all if you can wait for the conda version to catch up. Using the pip installer is not recommended, even if it often offers a more recent version.

  2. I install the most recent Tensorflow (here: 2.2) on Windows when conda does not yet support it

    Better do not use pip install at all if you can wait for the conda version to catch up. Using the pip installer is not recommended, even if it often offers a more recent version.

Method 1

1. Install into virtual environment with

pip TensorFlow

virtualenv --system-site-packages -p python3 ./venv

then you need to activate your new environment

pip install --upgrade pip

pip list  # show packages installed within the virtual environment
this command for quit 
deactivate  # don't exit until you're done using TensorFlow
we finish by installing tensor 

pip install --upgrade tensorflow

2. Install in your system

python3 --version
pip3 --version
virtualenv --version

Ubuntu

sudo apt update

sudo apt install python3-dev python3-pip

sudo pip3 install -U virtualenv  # system-wide install

then

pip3 install --user --upgrade tensorflow  # install in $HOME

Method 2

It’s possible to install TF 2.2.0 now with either:

pip install tensorflow-gpu==2.2.0

or

pip install https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-2.2.0-cp37-cp37m-win_amd64.whl

ONE IMPORTANT THING: for now, at least in my case, there is a major problem with the GPU version. The old one recognises my GPU with no issues, while the latest doesn’t see it for some reason. I advise you to create, just in case, a new env so you won’t need to reinstall everything later on.

EDIT by a reader:

Better do not use pip install at all if you can wait for the conda version to catch up. Using the pip installer is not recommended, even if it often offers a more recent version. Using pip will risk exactly the documented error here. And you do not need to create a new env with conda update, conda update --all will not harm your dependencies in your env.

Summery

It’s all About this issue. Hope all Methods helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which Method worked for you? Thank You.

Also, Read