close

How to pip install old version of library(tensorflow)?

Hello Guys, How are you all? Hope You all Are Fine. Today We Are Going To learn about How to pip install old version of library(tensorflow) in Python. So Here I am Explain to you all the possible Methods here.

Without wasting your time, Let’s start This Article.

Table of Contents

How to pip install old version of library(tensorflow)?

  1. How to pip install old version of library(tensorflow)?

    This works for me on Mac OS 10.13.1.
    pip install --user install tensorflow==1.3.0.

  2. pip install old version of library(tensorflow)

    This works for me on Mac OS 10.13.1.
    pip install --user install tensorflow==1.3.0.

Method 1

This works for me on Mac OS 10.13.1.

pip install --user install tensorflow==1.3.0. 

Method 2

You can install the pip wheel from a URL directly, for example:

# Ubuntu/Linux 64-bit, CPU only, Python 2.7
export TF_BINARY_URL=https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.11.0-cp27-none-linux_x86_64.whl
pip install --ignore-installed --upgrade $TF_BINARY_URL

In general, installation instructions for older versions of TensorFlow can be found at : For binaries for installation using wheels: Go to tensorflow pypi release history, select the release of your choice, say tensorflow 1.8.0 , go to Download files and either download the wheel file and then install or copy the download link and save in TF_BINARY_URL for your python --version and os [mac, linux or windows] install as shown above

Summery

It’s all About this issue. Hope all Methods helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which Method worked for you? Thank You.

Also, Read