close

[Solved] How to solve ImportError: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via `pip install tensorflow`?

Hello Guys, How are you all? Hope You all Are Fine. Today I get the following error How to solve ImportError: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via pip install tensorflow? in Python. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How How to solve ImportError: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via pip install tensorflow? Error Occurs?

How to solve ImportError: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via pip install tensorflow Error ?

  1. How to solve ImportError: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via pip install tensorflow Error ?

    to solve ImportError: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via pip install tensorflow Error Please update keras version. python -m pip install –upgrade pip

Solution 1

Tensorflow requires Python 3.5–3.8 , pip and venv >= 19.0

in order to fix it:

sudo apt install python3-pip

pip3 install --upgrade pip

python3 -m pip install tensorflow

if you already had tensorflow installed substitute the last command this this:

pip3 install --upgrade tensorflow 

hope it helped.

Solution 2

ImportError: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via pip install tensorflow

Fix:

python -m pip install –upgrade pip
pip install keras==2.1.5

This worked for me.

If above step are not solving the error then check your libraries with specific version.

Python==3.6.4
Numpy==1.18.5
Pandas==1.1.4
scikit-learn==0.21.2
Tensorflow==1.13.1
keras==2.1.5 

Hope this worked for you.

Solution 3

Please update keras version.

python -m pip install –upgrade pip

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you? Thank You.

Also Read

Leave a Comment