close

[Solved] Issues installing PyTorch 1.4 – “No matching distribution found for torch===1.4.0”

Hello Guys, How are you all? Hope You all Are Fine. Today I get the following error Issues installing PyTorch 1.4 – “No matching distribution found for torch===1.4.0” in Python. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How Issues installing PyTorch 1.4 – “No matching distribution found for torch===1.4.0” Error Occurs?

I get the following error Issues installing PyTorch 1.4 – “No matching distribution found for torch===1.4.0” in Python.

How To Solve Issues installing PyTorch 1.4 – “No matching distribution found for torch===1.4.0” Error ?

  1. How To Solve Issues installing PyTorch 1.4 – “No matching distribution found for torch===1.4.0” Error ?

    To Solve Issues installing PyTorch 1.4 – “No matching distribution found for torch===1.4.0” Error check your python version, my version is python 3.8.2 and it can't find a torch version matched the py version. And I use a 3.7.6 now, I suppose the version below 3.8 would be fine

Solution 1

Looks like this issue is related to virtual environment. Did you try recommended installation line in another/new one virtual environment? If it doesn’t help the possible solution might be installing package using direct link to PyTorch and TorchVision builds for your system:

pip install https://download.pytorch.org/whl/cu101/torch-1.4.0-cp38-cp38-win_amd64.whl

pip install https://download.pytorch.org/whl/cu101/torchvision-0.5.0-cp38-cp38-win_amd64.whl

Solution 2

check your python version, my version is python 3.8.2 and it can’t find a torch version matched the py version. And I use a 3.7.6 now, I suppose the version below 3.8 would be fine

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you? Thank You.

Also Read

Leave a Comment