close

[Solved] Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip

Hello Guys, How are you all? Hope You all Are Fine. Today I get the following error Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip in python. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip Error Occurs?

Today I get the following error Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip in python.

How To Solve Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip Error ?

  1. How To Solve Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip Error ?

    To Solve Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip Error brew install gdal and then pip install gdal solved this for me

  2. Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip

    To Solve Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output – while installing auto-py-to-exe through pip Error brew install gdal and then pip install gdal solved this for me

Solution 1

Edit

Since this answer was posted, gevent has released several new versions, including prebuilt wheels for Python 3.8 on Windows, so the pip install gevent --pre shouldn’t be necessary anymore – just run pip install auto-py-to-exe as usual and it should work.

Original answer

Allow prerelease gevent versions via

$ pip install gevent --pre
$ pip install auto-py-to-exe

Explanation: auto-py-to-exe is installable on Python 3.8 on Windows without any issues (this can be verified e.g. by running pip install auto-py-to-exe --no-deps). However, it requires bottle-websocket to be installed, which in turn has gevent dependency. gevent did not release a stable version that offers prebuilt wheels for Python 3.8 yet (this would be 1.5), so pip doesn’t pick up prebuilt wheels and tries to build gevent==1.4 from source dist. Installing the prerelease 1.5 version of gevent avoids this.

Solution 2

for installing GDAL on mac:

brew install gdal and then pip install gdal solved this for me

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you? Thank You.

Also, Read