close

[Solved] Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin ‘com.android.internal.application’

Hello Guys, How are you all? Hope You all Are Fine. Today I am facing the following error Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin ‘com.android.internal.application’ in Java. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin ‘com.android.internal.application’ Error Occurs?

Today I am facing the following error Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin ‘com.android.internal.application’ in Java.

How To Solve Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin ‘com.android.internal.application’ Error ?

  1. How To Solve Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin 'com.android.internal.application' Error ?

    To Solve Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin 'com.android.internal.application' Error For Windows -> File-> Settings-> Build,Execution,Deployment-> Build Tools-> Gradle-> Gradle JDK and select java 11

  2. Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin 'com.android.internal.application'

    To Solve Error: Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. -& Failed to apply plugin 'com.android.internal.application' Error For Windows -> File-> Settings-> Build,Execution,Deployment-> Build Tools-> Gradle-> Gradle JDK and select java 11

Solution 1

Well I also face same issue

Image showing same error

What worked for me is this (In Windows 10 OS based Laptop)

Go to File–>Settings–>Build,Execution,Deployment–>Build Tools–>Gradle

Now here –>Gradle JDK change 1.8 to 11(given in dropdown).

See image given to get more clear idea.

Steps to get Answer to given problem

After that just REBUILD YOU PROJECT. It worked for me. (see attached image). 

SO ERROR IS SOLVED AND EVERY THING IS FINE IN PROJECT NOW.

HOPE THIS WORKS FOR YOU TOO! THANKS.

Solution 2

For Windows -> File-> Settings-> Build,Execution,Deployment-> Build Tools-> Gradle-> Gradle JDK and select java 11

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you? Thank You.

Also, Read