close

[Solved] Pip: could not find a version. No matching distribution found

Hello Guys, How are you all? Hope You all Are Fine. Today I get the following error Pip: could not find a version. No matching distribution found in python. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How Pip: could not find a version. No matching distribution found Error Occurs?

Today I get the following error Pip: could not find a version. No matching distribution found in python.

How To Solve Pip: could not find a version. No matching distribution found Error ?

  1. How To Solve Pip: could not find a version. No matching distribution found Error ?

    To Solve Pip: could not find a version. No matching distribution found Error Pay attention if your file ~/.pip/pip.conf not contain any additional index-url values. Then it can trying to look for specific package version in repository that not exists.

  2. Pip: could not find a version. No matching distribution found

    To Solve Pip: could not find a version. No matching distribution found Error Pay attention if your file ~/.pip/pip.conf not contain any additional index-url values. Then it can trying to look for specific package version in repository that not exists.

Solution 1

The developers of Flask-ACL made a mistake that they did not manage to upload the Flask-ACL library onto PyPi(where pip searches for modules). so you will have to install it using pip from their GitHub page.

You can do so like this:

pip install "git+https://github.com/mikeboers/Flask-ACL"

Solution 2

Pay attention if your file ~/.pip/pip.conf not contain any additional index-url values. Then it can trying to look for specific package version in repository that not exists.

Some workaround solution is to remove pip.conf

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you? Thank You.

Also, Read