close

[Solved] Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support

Hello Guys, How are you all? Hope You all Are Fine. Today I get the following error Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support in python. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support Error Occurs?

Today I get the following error Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support in python.

How To Solve Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support Error?

  1. How To Solve Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support Error ?

    To Solve Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support Error As @COLDSPEED so eloquently pointed out the error explicitly tells you to install xlrd.

  2. Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support

    To Solve Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support Error As @COLDSPEED so eloquently pointed out the error explicitly tells you to install xlrd.

Solution 1

As @COLDSPEED so eloquently pointed out the error explicitly tells you to install xlrd.

pip install xlrd

And you will be good to go.

Solution 2

Since December 2020 xlrd no longer supports xlsx-Files as explained in the official changelog. You can use openpyxl instead:

pip install openpyxl

And in your python-file:

import pandas as pd
pd.read_excel('path/to/file.xlsx', engine='openpyxl')

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you? Thank You.

Also, Read